
Power BI Lab Problems - Step-by-Step Explanation(1-10) 

1)*** What is Data, Where to Find Data, Foundations for Building Data 

Visualization, Create Your First Visualization in Power BI*** 
 

1. What is Data? 

Data is the basic unit of information used for analysis and decision-making. It can be 

numerical (e.g., sales amount), textual (e.g., customer names), or categorical (e.g., product 

types). 

Example Table: 

Product Category Sales 

Laptop Electronics 1000 

Phone Electronics 800 

Table Furniture 600 

 

 

Output: Power BI uses this table as a data model to generate meaningful visualizations. 

2. Where to Find Data? 
Data can come from various sources. Power BI supports connecting to: 

- File sources: Excel, CSV, XML, JSON 

- Databases: SQL Server, MySQL, Oracle 

- Online services: SharePoint, Web APIs, etc. 

Example: You download a CSV file called sales_data.csv with the above data. 

Steps in Power BI: 

1. Open Power BI Desktop 

2. Click Home > Get Data > Text/CSV 

3. Select the file sales_data.csv 

4. Click Load 

Output: Power BI imports your data and displays it in the Fields pane. 

3. Foundations for Building Data Visualization 
Before creating visualizations, ensure: 

- Data is clean (no missing values) 



- Correct data types (numbers, text, dates) 

- Relationships between tables are defined (in case of multiple tables) 

- Visual goals are clear 

Choosing the Right Chart: 

Goal Chart Type 
Compare values Bar/Column 
Show trends Line Chart 
Show proportions Pie/Donut Chart 
Geographic data Map Chart 

4. Create Your First Visualization in Power BI 
Step-by-step guide using example dataset: 

Dataset: 

product category sales 
Laptop Electronics 1000 
Phone Electronics   800 
Table Furniture      600 

 

Step 1: Load the Data 

- Open Power BI Desktop 

- Click Home > Get Data > Text/CSV 

- Select your CSV file and click Load 

Step 2: Create a Bar Chart 

- In the Visualizations pane, click on the Clustered Bar Chart 

- Drag Product to the Y-Axis 

- Drag Sales to the X-Axis 

Step 3: Format the Chart 

- Click on the Format (paint roller) icon 

- Title: 'Product Sales' 

- Data labels: Turn ON 

- Color: Change bar color 

Output: 

Bar Chart - Product Sales 

1000 |■■■■■■■■■ Laptop 

 800 |■■■■■■■   Phone 

 600 |■■■■■     Table 



2)***Getting Started with Power BI Power BI Software & Data File Formats, How to 

Connect Data to Power BI, Create Basic Charts in Power BI, How to Use the Show Me 

Panel in Power BI**** 

 

1. Power BI Software & Data File Formats 
Power BI is a powerful business analytics tool developed by Microsoft. It helps users 

transform data into visually immersive and interactive insights. You can import data from a 

variety of file formats and sources. 

Supported Data File Formats: 

-  

Excel (.xlsx, .xls) 
- CSV (.csv) 
- Text (.txt) 
- JSON 
- XML 
- SQL Server and other databases 
- Web data sources (e.g., APIs, online tables) 

 

 

2. How to Connect Data to Power BI 
Steps to connect data: 

1. Open Power BI Desktop 

2. Click on 'Home > Get Data' 

3. Choose your data source (e.g., Excel, CSV) 

4. Browse and select the data file 

5. Click 'Load' to import data into Power BI 

Example: 

- File: sales_data.csv 

- Columns: Product, Category, Sales 

3. Create Basic Charts in Power BI 
A. Bar Chart 

- Visualizes data as rectangular bars. 

Steps: 

1. Select 'Clustered Bar Chart' from the Visualizations pane 

2. Drag 'Product' to Axis 



3. Drag 'Sales' to Values 

Output: A bar chart showing sales by product 

B. Line Chart 

- Shows trends over time. 

Steps: 

1. Select 'Line Chart' from the Visualizations pane 

2. Drag 'Date' to Axis 

3. Drag 'Sales' to Values 

Output: A line chart showing how sales change over time 

C. Tree Map 

- Visualizes hierarchical data with nested rectangles. 

Steps: 

1. Select 'Tree Map' from the Visualizations pane 

2. Drag 'Category' to Group 

3. Drag 'Sales' to Values 

Output: A tree map showing sales by category 

4. How to Use the Show Me Panel in Power BI 
Power BI doesn't have a 'Show Me' panel like Tableau, but it offers similar functionality 

through the 'Visualizations' pane. 

Power BI recommends visual types based on the fields you select. 

Steps: 

1. Select fields from the Fields pane 

2. Power BI auto-selects a visual, or you can choose from the Visualizations pane 

3. Customize using the Format panel 

Example: 

Selecting 'Sales' and 'Category' fields may automatically create a bar chart. 

You can then switch it to a pie chart or line chart using the Visualizations pane. 

Product Category Sales Date 

Laptop Electronics 1000 1/31/2024 

Phone Electronics 800 2/20/2024 

Tablet Electronics 600 3/31/2024 

Monitor Electronics 400 4/30/2024 

Keyboard Accessories 200 5/31/2024 

 
 



3)****Overview of Power BI Calculations, Aggregate Functions 
in Power BI, Custom Calculations and Fields***  

1. Overview of Power BI Calculations 
Power BI allows users to perform various calculations to analyze data. These calculations 

can be: 

- Aggregate calculations (SUM, AVERAGE, COUNT, MIN, MAX) 

- Custom calculations using DAX (Data Analysis Expressions) 

- Calculated columns and measures 

2. Sample Dataset (Sales Data) 
We'll use a simple Sales dataset for demonstration: 

OrderID Product Category Quantity UnitPrice SalesDate 
101 Pen Stationery 10 1.5 2024-01-05 
102 Notebook Stationery 5 3.0 2024-01-06 
103 Mouse Electronics 3 15.0 2024-01-07 
104 Keyboard Electronics 2 25.0 2024-01-08 
105 Pen Stationery 20 1.5 2024-01-09 

 

3. Step-by-Step in Power BI 
Step 1: Load Data 

1. Open Power BI Desktop 

2. Click on Home > Get Data > Excel/Text/CSV 

3. Select your file or paste your data into Enter Data 

4. Click Load 

4. Aggregate Functions in Power BI 

A. SUM Calculation 

Objective: Calculate total sales value. 

Create a new column for Sales: 

1. In the Data view, click on your table 

2. Go to Modeling > New column 

3. Enter the formula: 

   SalesAmount = [Quantity] * [UnitPrice] 

Now to get total sales: 

1. In Report View, insert a Card visual 



2. Drag the new column SalesAmount into the Values field 

3. It will automatically SUM the sales 

Output: 

Total SalesAmount = 15 + 15 + 45 + 50 + 30 = 155 

B. AVERAGE Calculation 

Objective: Calculate average unit price. 

1. Insert a Card visual 

2. Drag UnitPrice field to Values 

3. Click dropdown on UnitPrice > Change aggregation to Average 

Output: AVERAGE(1.5, 3.0, 15.0, 25.0, 1.5) = 9.2 

C. COUNT and Other Aggregates 

You can also use COUNT, MIN, and MAX functions. 

Example DAX formulas: 

OrderCount = COUNT(Sales[OrderID]) 

MaxPrice = MAX(Sales[UnitPrice]) 

MinPrice = MIN(Sales[UnitPrice]) 

5. Custom Calculations and Fields 

A. Calculated Column 

Used when the result is needed per row. 

Example: Add a Tax column (10% tax on each sale) 

DAX: TaxAmount = [SalesAmount] * 0.10 

B. Measure (Dynamic Aggregation) 

Measures are more efficient for summaries and aggregations. 

Example: 

TotalSales = SUM(Sales[SalesAmount]) 

C. Conditional Measure Example 

Suppose you want High Sales if SalesAmount > 20 

DAX: HighSalesFlag = IF([SalesAmount] > 20, "High", "Low") 

6. Example Report Layout 
- Card showing Total Sales = 155 

- Card showing Avg Unit Price = 9.2 

- Table visual showing each product with Quantity, UnitPrice, SalesAmount, Tax 

- Bar Chart: Category vs Total Sales 



7. Summary 
Concept Tool/Feature Used Example 
Aggregation (SUM) Card, Measure TotalSales = SUM(...) 
Average Card, Direct Field Drag UnitPrice > Avg 
Calculated Column Column in Data View SalesAmount = Quantity * 

UnitPrice 
Conditional Fields IF in DAX IF(SalesAmount > 20, ...) 
Measures New Measure (DAX) SUM(...), AVG(...) 

 

4)**** Applying New Data Calculations and Formatting 
Visualizations, Formatting tools and menus, Formatting specific 
parts of the view**** 

1. What Are Data Calculations in Power BI? 
Power BI lets you perform custom calculations using DAX (Data Analysis Expressions). 

These calculations allow you to create new columns or measures for analysis. 

There are two main types of calculations: 

- **Calculated Columns**: These are added to your table and calculated row-by-row. They 

are useful when you need a new field in the table itself. 

- **Measures**: These are dynamic calculations that aggregate data based on filters and 

slicers in your report. Measures are not stored in tables, they are calculated when needed. 

2. Sample Dataset 
We will use the following sample dataset for all our calculations and visuals. You can enter 

this manually or import it from Excel/CSV: 

OrderID Product   Quantity UnitPrice Category     
1 Pen     10 1.5 Stationery 
2 Notebook 5 2.0 Stationery 
3 Mouse      3 15.0 Electronics 
4 Keyboard   2 25.0 Electronics 
5 Pen 20 1.5 Stationery 

3. Step-by-Step: Load Data into Power BI 
• Open Power BI Desktop 

• Click on 'Home' > 'Enter Data' 

• Paste the above table manually (or load from Excel/CSV) 

• Click 'Load' 



4. Create a Calculated Column Using DAX 
We want to calculate SalesAmount for each row as Quantity * UnitPrice. 

Steps: 

1. Go to the Data View (click on the table icon in the left panel). 

2. Click on 'Modeling' tab, then click 'New Column'. 

3. In the formula bar, enter: 

   `SalesAmount = Sales[Quantity] * Sales[UnitPrice]` 

4. Press Enter. A new column named SalesAmount will appear in your table. 

5. Create a Measure to Show Total Sales 
Now let’s create a dynamic total of all sales, which updates based on filters. 

Steps: 

1. Click on 'Modeling' tab and select 'New Measure'. 

2. Enter the following formula: 

   `TotalSales = SUM(Sales[SalesAmount])` 

3. Press Enter. This measure can now be used in visuals like cards or charts. 

6. Apply the Calculation to a Visual 
Let’s create a bar chart to show Total Sales by Category. 

Steps: 

1. Click on the Report View (canvas icon). 

2. Click the Bar Chart icon from the Visualizations pane. 

3. Drag 'Category' into the Axis field. 

4. Drag 'TotalSales' into the Values field. 

Now your bar chart will display total sales for each category. 

7. Formatting the Visual 
To make the visual more attractive and readable: 

1. Select the visual, then click the Format icon (paint roller). 



2. Turn on the Title, set font size and color. 

3. Turn on Data Labels to show values directly on the bars. 

4. Customize background, border, and font as needed. 

8. Formatting Specific Parts of the View 
Power BI allows detailed formatting of individual components in your visuals: 

- Axis Titles: Customize font, size, orientation. 

- Data Bars: Use data bars inside tables. 

- Conditional Formatting: Apply rules to change color based on value. 

- Themes: Apply prebuilt color palettes to your report. 

 

Steps: 

1. Select a visual (e.g., Table or Matrix). 

2. Go to Format pane > Conditional Formatting. 

3. Choose 'Background color' or 'Font color'. 

4. Define rules (e.g., value > 1000 = green, < 1000 = red). 

 

9. Output & Explanation 
Using the dataset, you will get the following SalesAmount calculations: 

- Pen: 10 * 1.5 = 15 

- Notebook: 5 * 3.0 = 15 

- Mouse: 3 * 15.0 = 45 

- Keyboard: 2 * 25.0 = 50 

- Pen: 20 * 1.5 = 30 

Total Sales by Category: 

- Stationery = 60 (15+15+30) 

- Electronics = 95 (45+50) 

Grand Total = 155 

 

Card visual shows 155 as total sales. Bar chart shows 60 vs. 95 by category. 



Summary – Key Concepts You Learned 
• DAX: Used to create custom formulas 

• Calculated Column: Adds new column per row 

• Measure: Creates dynamic, filter-sensitive calculations 

• Formatting Tools: Improve visual appearance of visuals and layout 

10. More DAX Functions 
AverageSales = AVERAGE(Sales[SalesAmount]) 

MinSales = MIN(Sales[SalesAmount]) 

MaxSales = MAX(Sales[SalesAmount]) 
TotalOrders = COUNT(Sales[OrderID]) 
UniqueProducts = DISTINCTCOUNT(Sales[Product]) 
UnitProfit = DIVIDE(Sales[SalesAmount], Sales[Quantity]) 

 

11. Difference: Calculated Columns vs Measures 
Calculated Column: 

- Stored in the data table 

- Computed row by row 

- Doesn’t change with filters 

Measure: 

- Not stored, calculated on the fly 

- Changes dynamically based on slicers/filters 

- Better for aggregations, KPIs, and totals 

Column Stored Reacts to Filters Use For 
Yes   Per row No                 New field per row 
No Dynamic Yes Totals, KPIs, 

averages 

12. Conditional Formatting 
1. Click a table or matrix visual. 

2. In the Values section, click the dropdown for SalesAmount. 

3. Choose 'Conditional Formatting > Background color'. 



4. Set rules: 

   - Values >= 50: Green 

   - Values < 50: Red 

13. Tooltip Enhancements 
Tooltips provide more data when you hover on a chart. 

1. Select a visual (e.g., bar chart). 

2. Drag 'Quantity' and 'Product' fields into the 'Tooltips' well. 

3. Hover over the bars to see detailed information in a popup. 

14. Sort, Group, and Drill Down Visuals 
Power BI lets you enhance visuals with sorting and hierarchy: 

- Click the visual > More options (three dots) > Sort by TotalSales descending. 

- Create hierarchy like Category > Product and use Drill Down arrows. 

- Group similar values (e.g., sales ranges) to simplify visuals. 

15. Real-Life Reporting Use Case 
Imagine your manager asks for a report that shows: 

- Total sales across all categories 

- Sales by each category with colored bars 

- Tooltip with product and quantity 

- Sort bars from high to low 

Using calculated fields, measures, visuals, tooltips and formatting, you can build such a 

dashboard with ease. 

16 Applying New Data Calculations to Your Visualizations 
Power BI allows you to create custom calculations that enhance your analysis. These 

calculations can be created using DAX (Data Analysis Expressions). Calculations include: 

- Calculated Columns: Added at the row level of a table. 

- Measures: Aggregate results based on filters applied to visuals. 



- Quick Measures: Predefined calculations that simplify DAX creation. 

 

Example: If your dataset has 'Price' and 'Quantity' columns, create a new measure as: 

    Total Sales = SUM(Sales[Price] * Sales[Quantity]) 

 

Steps to create a Measure: 

1. Open Power BI Desktop. 

2. Go to the 'Modeling' tab. 

3. Click 'New Measure'. 

4. Enter the DAX formula. 

5. Press Enter and use the new measure in any visual. 

 

16.1 Formatting Visualizations 
Formatting is essential for clarity and design. The Format pane (paint roller icon) contains 

tools to customize your visuals. 

Key formatting areas: 

- Data colors 

- Labels and titles 

- Background and borders 

- Axis and gridlines 

 

Steps: 

1. Click on a visual to activate it. 

2. Open the 'Format' pane on the right. 

3. Explore the options: Titles, Labels, Data Colors, Borders, etc. 

4. Use toggles and sliders to change visual appearance. 

 

16.2 Formatting Tools and Menus 
The Format pane dynamically changes based on the selected visual. Each section in the pane 

controls different visual parts. 

Common Tools and Menus: 

- Title: Change font, alignment, and color. 

- Data Labels: Show value labels on bars or columns. 

- Legend: Adjust position, text size, and visibility. 

- Tooltips: Add interactivity by customizing information on hover. 

- Visual Header: Modify icons like filter, focus mode, etc. 

 



Steps: 

1. Select a visual. 

2. Click on the Format pane. 

3. Expand and adjust desired formatting sections. 

5)**** Editing and Formatting Axes in Power BI, 

Manipulating Data in Power BI, Pivoting Power BI Data 

(Unpivot and Pivot) *** 

1. Editing and Formatting Axes in Power BI 

Scenario: 

You have a Sales dataset showing Year, Product Category, and Total Sales. 

Steps to Edit and Format Axes: 

Step 1: Load Data 

1. Open Power BI Desktop. 

2. Click “Get Data” > Excel/CSV and load the dataset. 

3. Sample dataset: 

Year Product Category Total Sales 

2021 Electronics 50000 

2022 Clothing 30000 

2023 Furniture 40000 

Step 2: Create a Bar Chart 

1. Go to Visualizations pane and select Clustered Bar Chart. 

2. Drag Year to Axis. 

3. Drag Total Sales to Values. 

Step 3: Format the Axis 

1. Click on the chart > Go to “Format” pane (paint roller icon). 

2. Expand X-Axis or Y-Axis. 

3. Key formatting options: 



• Title: Toggle On/Off or rename. 

• Text Size: Increase for better visibility. 

• Start/End values: Manually define the axis range. 

• Display Units: Show values in K, M, B (e.g., 50K). 

• Gridlines: Toggle visibility or change color/thickness. 

Output Explanation: 

• X-Axis shows Year, formatted with larger font and visible gridlines. 

• Y-Axis shows Total Sales, rounded to K for clarity (e.g., 50K). 

• Helps in better visual interpretation of year-wise sales. 

2. Manipulating Data in Power BI 

Scenario: 

You want to create a new column that calculates Discounted Sales at 10% discount. 

Steps: 

Step 1: Load Data 

Use the same dataset. 

Step 2: Add Calculated Column 

1. In Data view, click Modeling > New column. 

2. Enter DAX: 

Discounted Sales = SalesData[Total Sales] * 0.9 

3. Press Enter. 

Step 3: Add a New Measure (Optional) 

1. Go to Modeling > New measure. 

2. Example: 

Total Discount = SUM(SalesData[Discounted Sales]) 

Output Explanation: 

• New column Discounted Sales shows the sales after applying a 10% discount. 



• This manipulation helps in understanding net revenue after discount. 

3.Pivoting Power BI Data (Unpivot and Pivot) 

Scenario: 

You have this table: 

Product Jan Feb Mar 
A 100 150 200 
B 200 250 300 

 

You want to convert it into: 

Product Month Sales 
A Jan 100 
A Feb 150 
A Mar 200 
B Jan 200 
B Feb 250 
B Mar 300 

Steps to Unpivot: 

Step 1: Load Data into Power Query 

1. Go to Home > Transform Data 

2. Select the table. 

Step 2: Unpivot Columns 

1. Select columns Jan, Feb, and Mar. 

2. Right-click > Select Unpivot Columns. 

Step 3: Rename Columns 

• Attribute → Month 

• Value → Sales 

Step 4: Close & Apply 

Click 'Close & Apply' to load the transformed data into Power BI. 

Output Explanation: 

• You now have a normalized table, ideal for creating visuals by month. 

• Great for line charts, trend analysis, or forecasting. 

 

 



    (OR) 

Power BI: Editing Axes, Manipulating Data, and Pivoting Data 

1. Editing and Formatting Axes in Power BI 

What It Means: 

Axes in Power BI visuals help you represent categories (e.g., years, products) and values 

(e.g., sales, revenue). Editing and formatting axes means changing how these labels and 

scales appear on your chart for better readability and style. 

Why It's Important: 

- Improves clarity of visualizations 

- Highlights specific trends 

- Matches formatting to your needs 

Key Formatting Options: 

- Axis Title: Rename or toggle visibility 

- Text Size and Color: Adjust for readability 

- Start and End Values: Define custom ranges 

- Display Units: Switch to K (thousand), M (million), etc. 

- Gridlines: Show or hide, change color/thickness 

Example: 

Dataset: 

Year | Product Category | Total Sales 

---- | ---------------- | ----------- 

2021 | Electronics      | 50000 

2022 | Clothing         | 30000 

2023 | Furniture        | 40000 

Steps: 

1. Create a Bar Chart. 

2. Drag 'Year' to Axis and 'Total Sales' to Values. 

3. Go to Format pane > Adjust X-Axis and Y-Axis settings. 

Output: A chart with clearly labeled years and readable sales values with adjusted scaling. 

2. Manipulating Data in Power BI 

What It Means: 



Manipulating data refers to transforming, calculating, and enriching your dataset by 

creating new columns or measures using DAX formulas or Power Query. 

Why It's Important: 

- Allows detailed calculations 

- Helps track KPIs like discount, profit, growth 

- Enables advanced reporting and visualizations 

Types of Manipulation: 

- Calculated Columns: Row-by-row logic 

- Measures: Aggregated metrics 

- Logical Conditions: IF, SWITCH, etc. 

- Date Transformations: Month, Year, Quarter 

Example: 

Create a new column with 10% discount applied: 

DAX: Discounted Sales = SalesData[Total Sales] * 0.9 

You can also create a measure: 

Total Discount = SUM(SalesData[Discounted Sales]) 

Output: A new column showing discounted revenue to understand net earnings. 

3. Pivoting and Unpivoting Data in Power BI 

What It Means: 

Pivoting turns row data into columns, while unpivoting turns columns into rows. Power BI 

uses unpivoting for better charting and filtering. 

Why It's Important: 

- Helps convert wide data into long format 

- Enables trend analysis over time 

- Supports better filtering and aggregations 

Example: 

Original Table: 

 

Product Jan Feb Mar    
A 
B 

100 
200 

150 
250 

200  
300 



Steps to Unpivot: 

1. Load into Power Query. 

2. Select Jan, Feb, Mar columns. 

3. Right-click > Unpivot Columns. 

4. Rename 'Attribute' to 'Month' and 'Value' to 'Sales'. 

Output Table: 

 

Product Month   Sales  

A               Jan        100    
A                Feb       150    
A               Mar       200    
B                 Jan       200    
B               Feb       250    
B                Mar      300    

 

This structure works perfectly for line and bar charts showing sales by month. 

 

6)****Power BI Guide: Structuring, Sorting, Filtering, and 
Pivoting Data**** 

1. Structuring Data in Power BI 
Structuring data means cleaning, organizing, and formatting raw datasets into a usable 

format. 

Step-by-step Process: 

1. Load Data: Home > Get Data > Choose your file 

2. Rename Columns: Double-click header and rename 

3. Change Data Types: Right-click column > Change Type 

4. Split Full Name: Transform > Split Column > By Delimiter 

5. Remove Null Rows: Home > Remove Rows > Remove Blank Rows 

6. Create New Column: Add Column > Custom Column 

Example Output: 

First Name Last Name     Sales                     Commission                    | Date | 

 

 

John 

Doe                 1000                     100                                     | 2024-01-10  



2. Sorting and Filtering Tableau-like Data in Power BI 
Power BI supports interactive sorting and filtering similar to Tableau. 

Sorting Example: 

1. Create a bar chart with Product Name and Total Sales 

2. Click three dots on visual > Sort by Total Sales 

3. Select descending order to show top products 

Filtering Options: 

- Visual Level Filter: Filters only selected visual 

- Page Level Filter: Filters all visuals on current page 

- Report Level Filter: Filters across all pages 

Example Output: 

A bar chart filtered to show sales of top 5 products in North and West regions, sorted by 

Total Sales. 

3. Pivoting Tableau Data in Power BI 
Pivoting in Tableau is similar to unpivoting in Power BI to make data analysis-friendly. 

Steps to Unpivot: 

1. Load data into Power Query Editor 

2. Select month columns (e.g., Jan, Feb, Mar) 

3. Click Transform > Unpivot Columns 

4. Rename 'Attribute' to 'Month' and 'Value' to 'Sales' 

Example Output: 

Before: 

| Product | Jan     | Feb | Mar | 
|---------     |-----     |-----|-----| 
| A               | 100    | 150 | 120 | 

After Unpivoting: 

| Product | Month | Sales | 

|---------|-------|--------| 

| A       | Jan   | 100    | 

| A       | Feb   | 150    | 

| A       | Mar   | 120    | 

 



7)****Advanced Visualization Tools in Power 

BI***** 

1. Using Filters 

Filters allow you to limit what data is displayed in a visual or the entire report. 

Example: 

You want to analyze product sales only for the 'East' region. 

Steps: 

Add a bar chart with 'Product Name' on Axis and 'Total Sales' on Values. 

In the Filters pane, drag 'Region' to 'Filters on this visual'. 

Select only 'East' as the filter value. 

Output: 

The bar chart will now only display product sales for the East region. 

2. Using the Details Panel 

The Details panel allows you to break down data further within visuals. 

Example: 

Add 'Salesperson' to the Details well of a clustered column chart displaying 'Product Name' 

and 'Total Sales'. Each bar will show breakdown details for each salesperson. 

3. Using the Size Panel 

Use the Size panel in visuals like scatter or bubble charts to reflect a numeric field as bubble 

size. 

Example: 

In a scatter chart with 'Sales' on X-axis and 'Profit' on Y-axis, adding 'Profit Margin' to the 

Size well makes bubbles larger for higher margins. 

4. Customizing Filters 

Customize slicers or filters to improve user interactivity and report aesthetics. 

Steps: 

Add a slicer visual with the 'Year' field. 



In the Format pane, set orientation, enable dropdown mode or single select. 

Users can now dynamically filter the page using the slicer. 

5. Using and Customizing Tooltips 

Tooltips display more information when you hover over a visual element. 

Steps: 

Select a chart and drag fields like 'Profit' and 'Region' to the Tooltip field well. 

Optionally, create a report page with visuals and set it as a tooltip. 

When hovering, extra context is shown like region and profit. 

6. Formatting Your Data with Colours 

Conditional formatting adds visual emphasis to trends and performance. 

Steps: 

Select a bar chart visual. 

Go to Format > Data colors > fx button. 

Choose to color by 'Sales' using a scale (e.g., red for low, green for high). 

Output: 

Bars change color based on sales performance. 

Sample Data Table 

This is the sample dataset used for demonstration: 

Product 

Name 

Region Sales Profit Profit 

Margin 

Salesperson Year 

Laptop East 15000 3000 0.2 Alice 2022 

Tablet West 12000 2500 0.21 Bob 2022 

Smartphone East 18000 4000 0.22 Alice 2023 

Monitor North 9000 1500 0.17 Charlie 2023 

Printer South 5000 800 0.16 David 2022 

 



8)**** Power BI Dashboard and Storytelling Concepts**** 

1. Create Your First Dashboard and Story 

**Objective:** Combine visuals from multiple reports to build an insightful and interactive 

dashboard. 

Steps: 

Create a report in Power BI Desktop by importing your dataset (e.g., Sales.xlsx). 

Build visuals: bar charts (Sales by Product), pie charts (Sales by Region), etc. 

Click File > Publish > Publish to Power BI and choose your workspace. 

In Power BI Service, click “+ Create” > Dashboard and name it (e.g., Sales Overview). 

Open your report in Power BI Service and click the pin icon to pin visuals to the dashboard. 

Arrange visuals logically, add Text Boxes for context, and use KPIs and slicers. 

Example: 

Pin visuals like “Sales by Region”, “Profit Trend”, and a KPI showing “Monthly Target 

Achievement”. 

Output: 

An interactive dashboard showing sales performance, regional growth, and profit trends. 

2. Design for Different Displays 

**Objective:** Ensure your reports look great on desktops, tablets, and mobiles. 

Steps: 

Use consistent spacing and avoid overlapping visuals. 

Click View > Phone Layout and drag/arrange visuals for mobile view. 

Preview layout in Power BI Service > View > Mobile Layout. 

Use responsive visuals to allow resizing and adaptability. 

Example: 

Design a compact version of your Sales dashboard for mobile users using cards and a 

stacked column chart. 

Output: 



Responsive dashboards usable on desktops, tablets, or mobile phones. 

3. Adding Interactivity to Your Dashboard 

**Objective:** Make your dashboard dynamic so users can explore data on their own. 

Steps: 

Add slicers (e.g., by Region, Product, or Year). 

Create a separate page for drillthrough and use right-click to enable it. 

Drag additional fields into the Tooltip section of visuals or create tooltip pages. 

Use bookmarks to create different views and add navigation buttons. 

Example: 

Clicking a product filters all visuals to that product and tooltips show profit margins. 

Output: 

A highly interactive dashboard where users can filter, click, drill, and hover. 

4. Distributing & Publishing Your Visualization 

**Objective:** Make your Power BI reports available to others. 

Steps: 

Click Home > Publish in Power BI Desktop and choose a workspace. 

Open your dashboard/report in Power BI Service and click Share. 

Enter email addresses, enable sharing options. 

Click File > Export > PDF or PowerPoint if needed. 

Use Embed Report > SharePoint Online or add to Microsoft Teams. 

Set dataset refresh in Scheduled Refresh settings. 

Example: 

A monthly sales report is published, embedded in Teams, and refreshed daily. 

Output: 

Your team gets updated, interactive reports accessible across platforms. 

 



9)***Power BI File Types, Publishing, Sharing, and 

Exporting** 

1. Power BI File Types (with Extensions & Usage Examples) 

Power BI uses several file types. Here’s a detailed table that explains each file type, its 

extension, purpose, how to use it in Power BI, and a practical example: 

File Type Extension Purpose How to Use in 

Power BI 

Example 

Power BI 

Desktop File 

.pbix The primary 

working file—

contains data, 

queries, 

visuals, and 

data models. 

Open it with 

Power BI 

Desktop to 

build and edit 

reports, 

models, and 

DAX 

measures. 

SalesDashboard.pbix – 

Full monthly sales 

report. 

Power BI 

Template 

File 

.pbit A template 

file that 

contains the 

report 

structure 

without actual 

data. 

Open in 

Power BI 

Desktop; it 

prompts you 

to load your 

data to use 

the pre-built 

design and 

queries. 

MarketingTemplate.pbit 

– Predefined report 

layout. 

Excel File .xlsx A common 

external data 

source used 

to import 

datasets into 

Power BI. 

Import via 

Home > Get 

Data > Excel. 

CustomerList.xlsx – 

Used for customer 

segmentation. 

CSV File .csv A flat file 

format used 

to store and 

import 

tabular data. 

Import via 

Home > Get 

Data > 

Text/CSV. 

Sales2024.csv – 

Contains sales data 

across regions. 



Power BI 

Dataflow 

(Online) 

- A cloud-based 

data 

preparation 

solution 

shared across 

multiple 

reports. 

Create and 

manage in the 

Power BI 

Service under 

Workspaces > 

Dataflows to 

prep shared 

data models. 

“Sales ETL Dataflow” – 

Used by various 

reports. 

 

Usage Example: 

When you build a report in Power BI Desktop using your sales data, you save it as 

SalesDashboard.pbix. Later, if you want to share the report's structure without including 

confidential data, you can save a template as SalesTemplate.pbit and share that with 

colleagues. 

Output: 

You have files designed for specific purposes—the .pbix for full development and the .pbit 

for sharing clean templates. 

2. Publishing to Power BI Online 

Objective: 

Transfer your locally developed report into the Power BI Service so that you and your team 

can access it online. 

Steps: 

Open your .pbix file in Power BI Desktop. 

Click on File > Publish > Publish to Power BI. 

Sign into your Power BI account. 

Choose the appropriate workspace (e.g., “My Workspace” or a shared workspace). 

Once published, your report appears in Power BI Service under the “Reports” section. 

Example: 

Publishing SalesDashboard.pbix to the “Marketing Workspace”. 

Output: 

Your report is now available online, accessible via any browser. 

3. Sharing Your Visualization 

Objective: 

Allow others to view and interact with your published report or dashboard. 



Steps: 

Open the Report or Dashboard in Power BI Service. 

Click the “Share” Button: Enter email addresses of team members and set permissions. 

Alternative Sharing: Use “Get link” to generate a shareable URL or embed your report in 

SharePoint or Microsoft Teams. 

Example: 

Sharing a Sales Performance Dashboard with your marketing team so they can review 

quarterly trends. 

Output: 

Recipients receive an email invitation or link to view an interactive report on Power BI 

Service. 

4. Printing and Exporting 

Objective: 

Generate offline or static versions of your report for distribution or archival purposes. 

Steps: 

A. Export to PDF 

1. Open Report in Power BI Desktop or Service. 

2. Click File > Export > PDF. 

3. Follow prompts to save the file. 

B. Export to PowerPoint 

1. Open Report in Power BI Service. 

2. Click File > Export > PowerPoint. 

3. Each report page becomes a slide. 

C. Print Directly 

1. Click File > Print this page and choose your printer settings. 

Example: 

Export SalesDashboard.pbix as a PDF for a client meeting or as a PowerPoint to present 

insights. 

Output: 

You receive a static PDF or PPT file that mirrors your interactive report’s visuals—ideal for 

presentations or offline review. 



 

10)***** Custom Charts and Advanced Visualizations in 

Power BI*** 

1. Creating Custom Charts 

Objective: Create a tailored chart (e.g., bar chart with conditional formatting) to visualize 

specific insights. 

Example: Visualizing Sales by Region using color formatting based on value. 

Sample Data: 

Region Sales 

North 12000 

South 8000 

East 15000 

West 7000 

Steps: 

Load the sample data into Power BI. 

Insert a Clustered Bar Chart. 

Add 'Region' to Axis and 'Sales' to Values. 

Use the Format pane to apply Conditional Formatting in Data colors. 

Set rule: Sales > 10000 → Green; else → Red. 

Format chart title and labels. 

Output: A bar chart with color-coded regions for performance comparison. 

2. Cyclical Data with Circular Area Charts (Radar) 

Objective: Visualize repeating patterns (e.g., monthly trends) using a radar chart. 

Example: Monthly temperature trends. 

Sample Data: 



Month Temperature 

Jan 4 

Feb 6 

Mar 12 

Apr 18 

May 22 

Jun 28 

Jul 30 

Aug 29 

Sep 24 

Oct 16 

Nov 10 

Dec 5 

Steps: 

Import 'Radar Chart' from AppSource in Power BI. 

Insert Radar Chart visual. 

Add 'Month' to Category and 'Temperature' to Values. 

Format chart with labels, lines, and title. 

Output: A circular chart showing peak and low temperatures across the year. 

3. Dual Axis Charts 

Objective: Compare two different metrics with distinct scales using a combo chart. 

Example: Monthly Sales vs. Profit Margin % 

Sample Data: 

Month Sales Profit Margin (%) 

Jan 5000 10 



Feb 7000 12 

Mar 8500 15 

Apr 9200 14 

May 11000 17 

Jun 10500 13 

Steps: 

Insert 'Line and Clustered Column Chart'. 

Add 'Month' to Shared Axis. 

Add 'Sales' to Column Values and 'Profit Margin' to Line Values. 

Enable Secondary Axis for Profit Margin. 

Add labels, legend, and chart title. 

Output: A dual-axis chart comparing sales volume with profitability trends. 

Region Sales 
North 12000 
South 8000 

 


