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EXP1: Introduction to SPSS, Sorting File, Split File, Compute File, Recode File and Select 
Cases 

Aim:To study IBM SPSS Statistics software and to perform fundamental data management 
operations such as 

 Understanding the SPSS interface 
 Sorting cases in a dataset 
 Splitting the file for separate group analysis 
 Computing a new variable from existing variables 
 Recoding values of a variable into a new variable 
 Selecting specific cases for analysis 

Introduction to SPSS 

IBM SPSS Statistics (commonly referred to as SPSS) is a powerful and widely used statistical 
software suite developed for data management, advanced analytics, multivariate analysis, 
business intelligence, and predictive modeling. Originally standing for "Statistical Package for 
the Social Sciences," it was first launched in 1968. IBM acquired the software in 2009, and 
current versions (as of 2025, including versions around 29-31 and ongoing developments) are 
officially branded as IBM SPSS Statistics. 

SPSS is designed to help researchers, analysts, organizations, and students extract actionable 
insights from data through: 

 Robust statistical testing (e.g., descriptive statistics, t-tests, ANOVA, regression).  
 Predictive analytics and machine learning algorithms.  
 Data preparation, visualization (charts, graphs), and reporting.  
 Integration with open-source tools like Python and R for extensibility.  
 Handling complex data scenarios, including missing values, complex samples, and big 

data integration. 

It features a user-friendly graphical interface with point-and-click menus, making it accessible 
for beginners while offering advanced options via syntax (command-language scripting) for 
experienced users. SPSS supports importing data from various formats (e.g., Excel, CSV, 
databases) and is used across fields like social sciences, healthcare, marketing, education, and 
government research. 

 

 



Main Windows in SPSS 

When you launch SPSS, the Data Editor window opens by default: 

 Data View: Spreadsheet-like grid where rows represent cases (e.g., individual 
respondents or observations) and columns represent variables. This is where you enter, 
edit, and view actual data values. 

 Variable View: Displays metadata (information about variables). Each row represents a 
variable, with columns for properties such as: 

o Name: Short unique variable name (no spaces, starts with letter). 
o Type: Numeric, String, Date, etc. 
o Width/Decimals: Display format. 
o Label: Descriptive variable label (can include spaces). 
o Values: Value labels for categorical data (e.g., 1 = "Male", 2 = "Female"). 
o Missing: Codes for missing values. 
o Columns/Align: Display settings in Data View. 
o Measure: Level of measurement (Nominal, Ordinal, Scale). 
o Role: Input, Target, etc. (for certain procedures). 

Switch between these views using tabs at the bottom-left of the Data Editor. 

Other key windows: 

 Output Viewer: Displays results of analyses (tables, charts, logs). Saved with .spv 
extension. 

 Syntax Editor: For writing and running SPSS command syntax (advanced automation). 

Organization of Options (Menu Bar) 

The top menu bar provides access to all SPSS functions. Menus are logically grouped for 
workflow: from file handling and data manipulation to analysis and output. 

Key menus and their main options: 

 File: New/Open/Save data files; Import/Export data; Print; Recent files; Exit. 
 Edit: Undo/Redo; Cut/Copy/Paste; Find; Options (preferences, e.g., output settings). 
 View: Toggle toolbars, status bar, grid lines, value labels (in Data View); Menus 

(customize). 
 Data: Define variable properties; Sort cases; Merge files; Aggregate; Split File; Select 

Cases; Weight Cases. 



 Transform: Compute new variables; Recode variables; Categorize; Rank cases; 
Automatic Recode. 

 Analyze: Core statistical procedures. 
o Descriptive Statistics (Frequencies, Descriptives, Explore). 
o Compare Means (t-tests, ANOVA). 
o General Linear Model; Correlation; Regression. 
o Nonparametric Tests; Scale; Multivariate. 
o Tables (Custom Tables); Forecasting; Survival; etc. 

 Graphs: Chart Builder; Legacy Dialogs (bar charts, scatterplots, histograms); 
Graphboard Template Chooser.  

 Utilities: Variables info; Data File Comments; Display Dictionary.  
 Add-ons: Integration with extensions (e.g., Python/R); Manage custom dialogs.  
 Window: Switch between open windows (Data Editor, Output, Syntax).  
 Help: Tutorials; Documentation; Case studies; About SPSS (version info). 

Procedure (Basic Startup): 

1. Launch IBM SPSS Statistics. 
2. Explore the empty Data Editor (switch between Data View and Variable View). 
3. Go to File > Open > Data to load a sample dataset (e.g., demo.sav if available). 
4. Navigate the menu bar to familiarize with options. 
5. Run a simple analysis: Analyze > Descriptive Statistics > Frequencies to see output in 

the Viewer. 

 

 

 

 

 

 

  



1.A) Sorting File (Sort Cases) 

Aim:To rearrange the cases in the dataset based on the values of one or more variables in 
ascending or descending order. 

Procedure: 

1. Open your dataset in the Data Editor. 
2. Go to Data > Sort Cases. 
3. In the Sort Cases dialog box, select the variable(s) you want to sort by from the left list 

and move them to the "Sort By" box using the arrow button. 
4. For multiple variables, the primary sort variable is the first in the list, followed by 

secondary sorts. 
5. Choose Ascending (default, low to high) or Descending (high to low) for each variable 

by selecting it and clicking the option. 
6. Click OK. 
7. The dataset in Data View will now be reordered. Note: This permanently changes the row 

order unless you undo or re-sort. 
8. To return to original order, create an ID variable first (using Compute) before sorting. 

 

 

 

 

 

 

 

 

 

 

  



 

 

 

 

 

 



 

 

 

 

 



 

  

 

 



  

 



1.B )Split File 

Aim: To perform analyses separately for subgroups defined by one or more categorical variables 
without physically splitting the data file. 

Procedure Step by Step: 

1. Open your dataset. 
2. First, sort the data by the grouping variable: Data > Sort Cases, select the grouping 

variable, and click OK. (Recommended for organized output.) 
3. Go to Data > Split File. 
4. In the Split File dialog box, select Analyze all cases, do not create groups if currently 

split (to turn off), or choose: 
o Compare groups (output in single table comparing groups) or 
o Organize output by groups (separate tables for each group). 

5. Move the grouping variable(s) to the "Groups Based on" box. 
6. Click OK. 
7. Subsequent analyses (e.g., frequencies, descriptives) will be performed separately for 

each group. 
8. To turn off Split File: Repeat steps 3-4 and select Analyze all cases, do not create 

groups, then OK. 

  



 

 

 

 

 

 



 

 

 

  

 



1.C) Compute Variable 

Aim: To create a new variable based on computations (e.g., arithmetic, functions) from existing 
variables. 

Procedure Step by Step: 

1. Open your dataset. 
2. Go to Transform > Compute Variable. 
3. In the Compute Variable dialog box, enter the name of the new Target Variable (must 

be a new name). 
4. In the Numeric Expression box, build the formula: 

o Use the keypad or type directly. 
o Include existing variables (move from left list), operators (+, -, *, /, ** for power), 

and functions (e.g., MEAN, SUM, from the Functions list). 

Example: For average of three scores: MEAN(var1, var2, var3) 

5. Optionally, click Type & Label to set label or type for the new variable. 
6. Click OK. 
7. The new variable appears as a new column in Data View (at the end). 
8. Check results in Data View or run descriptives.  



 

 

 

 

 



 

 

 

 

 



1.D) Recode Variable 

Aim: To recode values of an existing variable into new values, creating a new variable 
(recommended to preserve original data). 

Procedure Step by Step (Recode into Different Variables): 

1. Open your dataset. 
2. Go to Transform > Recode into Different Variables. 
3. Move the input variable(s) to the "Input Variable -> Output Variable" box. 
4. For each, enter the Output Variable name and optionally label, then click Change. 
5. Click Old and New Values. 
6. In the Old and New Values dialog: 

o Specify Old Value (e.g., single value, Range, All other values) and New Value. 
o Click Add for each mapping. 
o Example: Old 1 -> New 0; Old 2 thru 5 -> New 1. 

7. Optionally, handle System-missing or copy old values. 
8. Click Continue, then OK. 
9. The new recoded variable appears in Data View. 
10. Add value labels in Variable View if needed. 

 

  



 

 

 

 



 

 

 

 



 

 

 

 



 

 

 

 



 

 

 

 



 

 

 

 



 

 

 

 

 



1.E)  Select Cases 

Aim: To temporarily select a subset of cases for analysis (e.g., based on conditions), filtering out 
others without deleting them. 

Procedure Step by Step: 

1. Open your dataset. 
2. Go to Data > Select Cases. 
3. Choose an option: 

o All cases (to reset). 
o If condition is satisfied (most common for conditional selection). 

4. For conditional: Click If. 
5. Build the expression (e.g., gender = 1 & age > 18). Use variables, operators (=, >, <, &, | 

for AND/OR). 
6. Click Continue. 
7. Choose output: Filter (creates filter variable, unselected cases hidden but kept) or Delete 

(permanently removes unselected). 
8. Click OK. 
9. A filter variable appears; "Filter On" shows in status bar. Analyses use only selected 

cases. 
10. To reset: Repeat and select All cases, then OK. 

 

 

  



 

 

 

 

 

 



 

 

 

 

 

 



 

 

 

 

 

 



 

 

 

 

 

 



 

 

 

 

 

 



 

 

 

 

 

 



 

 

 

 

 

 



 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Results 

1.A: The sorting operation was successfully performed on the dataset. 

1.B:  The "Split File" command was successfully applied.  

 1.C: The computation of a new variable was completed successfully.  

1.D: The recoding operation was successfully executed using the "Recode into Different 
Variables" method. 

1.E: The selection of cases was successfully performed based on the specific condition provided. 

 



EXP2: Chi- Square Test (Parametric and Non-Parametric) 

Aim 

To apply the Chi-Square (χ²) Test in SPSS to: 

1. Test whether the observed frequency distribution of a single categorical variable 

significantly differs from a hypothesized (expected) distribution (Goodness-of-Fit Test-

non-parametric). 

2. Determine whether there is a significant association between two categorical variables 

(Test of Independence-parametric). 

Description: 

The Chi-Square (χ²) Test is a non-parametric statistical method used to analyze categorical data. 

It compares observed frequencies with expected frequencies to determine if significant differences 

exist (Goodness-of-Fit) or if two variables are associated (Test of Independence). 

Types 

1. Chi-Square Goodness-of-Fit Test 

o Used for one categorical variable. 

o Tests if the observed distribution matches a specified (often uniform) expected 

distribution. 

o Example: Is a die fair? (expected: equal counts for 1–6). 

2. Chi-Square Test of Independence 

o Used for two categorical variables in a contingency table. 

o Tests if the variables are independent or associated. 

o Example: Is there an association between gender and preferred sport? 

Formula 

χ² = Σ [(Oᵢ – Eᵢ)² / Eᵢ] 

Where: 

• Oᵢ = Observed frequency 

• Eᵢ = Expected frequency 

• Summation over all categories/cells 

  



Procedure: 

1. Chi-Square Goodness-of-Fit Test 

Step by step procedure: 

1. Prepare data: One categorical variable (preferably numeric codes, e.g., 1,2,3... with value 

labels). Example: Dice_Roll (1 to 6). 

2. Go to Analyze > Nonparametric Tests > Legacy Dialogs > Chi-Square. 

3. Move the categorical variable (e.g., Dice_Roll) to Test Variable List. 

4. Under Expected Values: 

o Select All categories equal (for uniform distribution, e.g., fair die). 

o OR select Values and enter custom expected proportions (they must sum to 1 if 

proportions, or counts). 

5. Click OK. 

Interpretation: 

• Compares observed vs. expected frequencies. 

• p-value (Asymp. Sig.): If p < 0.05, distribution differs significantly from hypothesized. 

p-value Decision Meaning 

p ≤ 0.05 Reject null hypothesis Significant → Die is likely unfair 

p > 0.05 Fail to reject null hypothesis Not significant → Die appears fair 

 

Expected Output: 

• Observed N and Expected N for each category. 

• Chi-Square value, df, Asymp. Sig. (p-value). 

• Footnote about expected counts <5 (if any). 

  



 
 

 

 
 

 

 

 



 
 

 

 
 



 
 

 

 
 

 

 

 

 



 
 

 

 

 

  



Output: 

GET DATA 

  /TYPE=XLSX 

  /FILE='D:\palab\c_goodnessoffit.xlsx' 

  /SHEET=name 'c_goodnessoffit' 

  /CELLRANGE=FULL 

  /READNAMES=ON 

  /DATATYPEMIN PERCENTAGE=95.0 

  /HIDDEN IGNORE=YES. 

EXECUTE. 

DATASET NAME DataSet2 WINDOW=FRONT. 

NPAR TESTS 

  /CHISQUARE=Color_Preference 

  /EXPECTED=EQUAL 

  /MISSING ANALYSIS. 

 

 

NPAR TESTS 

  /CHISQUARE=Dice_Roll 

  /EXPECTED=EQUAL 

  /MISSING ANALYSIS. 

 

 

 

NPar Tests 

 

Chi-Square Test 

 

Frequencies 

 

Dice_Roll 

 Observed N Expected N Residual 

1 18 25.0 -7.0 

2 20 25.0 -5.0 

3 29 25.0 4.0 

4 24 25.0 -1.0 

5 28 25.0 3.0 

6 31 25.0 6.0 

Total 150   



 

 

Test Statistics 

 Dice_Roll 

Chi-Square 5.440a 

df 5 

Asymp. Sig. .365 

a. 0 cells (0.0%) have expected 

frequencies less than 5. The 

minimum expected cell 

frequency is 25.0. 

 

 

 

 

 

 

 

 

 

 

 



2. Chi-Square Test of Independence 

Step by step procedure: 

1. Go to Analyze > Descriptive Statistics > Crosstabs. 

2. Move one variable to Row(s) and the other to Column(s). 

3. Click Statistics button: 

o Check Chi-square. 

o Optionally check Phi and Cramer’s V (effect size). 

o Click Continue. 

4. Click Cells button: 

o Check Observed and Expected counts. 

o Check Row or Column percentages (for interpretation). 

o Click Continue. 

5. Click OK. 

Interpretation: 

• Look at the Crosstabulation table: Compare observed vs. expected counts. 

• In Chi-Square Tests table: Focus on Pearson Chi-Square row. 

o Asymp. Sig. (2-sided) = p-value. 

o If p < 0.05, significant association (variables are related). 

o Check footnotes for warnings (e.g., if expected counts < 5 in >20% of cells, 

results may be unreliable). 

• Effect size: Phi or Cramer's V (0.1 small, 0.3 medium, 0.5 large). 

Expected Output: 

• Crosstabulation table: Observed vs. Expected counts and percentages. 

• Chi-Square Tests table: Pearson Chi-Square row → Value, df, Asymp. Sig. (2-sided) p-

value. 

• Effect size (if selected): Cramer's V (0.1 = small, 0.3 = medium, 0.5 = large).  

• Footnotes: Warn if expected counts are low. 



 

 

 

 

 



 

 

 

 

 



 

 

 

 

 



 

 

 

 

 



 

 

 

 

 

 

 

 

 

 

 

 



Output: 

 

Your temporary usage period for IBM SPSS Statistics will expire in 3653 days. 

 

GET DATA 

  /TYPE=XLSX 

  /FILE='D:\palab\c_independence.xlsx' 

  /SHEET=name 'c_independence' 

  /CELLRANGE=FULL 

  /READNAMES=ON 

  /DATATYPEMIN PERCENTAGE=95.0 

  /HIDDEN IGNORE=YES. 

EXECUTE. 

 

DATASET NAME DataSet1 WINDOW=FRONT. 

CROSSTABS 

  /TABLES=Gender BY Favorite_Sport 

  /FORMAT=AVALUE TABLES 

  /STATISTICS=CHISQ PHI 

  /CELLS=COUNT EXPECTED ROW COLUMN TOTAL 

  /COUNT ROUND CELL. 

 

 

 

Crosstabs 

 

[DataSet1]  

 

Case Processing Summary 

 

Cases 

Valid Missing Total 

N Percent N Percent N Percent 

Gender * 

Favorite_Sport 

150 100.0% 0 0.0% 150 100.0% 

 

 

 

 

 



Gender * Favorite_Sport Crosstabulation 

 

Favorite_Sport 

Total Basketball Football Tennis 

Gender Female Count 15 5 50 70 

Expected Count 14.0 27.5 28.5 70.0 

% within Gender 21.4% 7.1% 71.4% 100.0% 

% within 

Favorite_Sport 

50.0% 8.5% 82.0% 46.7% 

% of Total 10.0% 3.3% 33.3% 46.7% 

Male Count 15 54 11 80 

Expected Count 16.0 31.5 32.5 80.0 

% within Gender 18.8% 67.5% 13.8% 100.0% 

% within 

Favorite_Sport 

50.0% 91.5% 18.0% 53.3% 

% of Total 10.0% 36.0% 7.3% 53.3% 

Total Count 30 59 61 150 

Expected Count 30.0 59.0 61.0 150.0 

% within Gender 20.0% 39.3% 40.7% 100.0% 

% within 

Favorite_Sport 

100.0% 100.0% 100.0% 100.0% 

% of Total 20.0% 39.3% 40.7% 100.0% 

 

 

Chi-Square Tests 

 Value df 

Asymptotic 

Significance 

(2-sided) 

Pearson Chi-Square 65.253a 2 .000 

Likelihood Ratio 73.873 2 .000 

N of Valid Cases 150   

a. 0 cells (0.0%) have expected count less than 5. The 

minimum expected count is 14.00. 

 

 

 

 

 

 

 



Symmetric Measures 

 Value 

Approximate 

Significance 

Nominal by 

Nominal 

Phi .660 .000 

Cramer's V .660 .000 

N of Valid Cases 150  

 

 

Results 

The two experiments were carried out successfully: 

1. Chi-Square Goodness-of-Fit Test on the dice roll data. 

2. Chi-Square Test of Independence on the Gender and Favorite_Sport data. 

 

 



Exploratory Factor Analysis (EFA) 

AIM:  

To perform Exploratory Factor Analysis (EFA) using SPSS in order to identify the underlying 

factors among a set of observed variables and to reduce the data into a smaller number of 

meaningful latent constructs. 

DESCRIPTION: 

Exploratory Factor Analysis (EFA) is a statistical method used in multivariate data analysis to 

identify the underlying structure among a set of observed variables. It aims to reduce a large 

number of variables into a smaller set of latent (unobserved) factors that explain the patterns of 

correlations or covariances in the data. EFA is "exploratory" because it doesn't start with a 

predefined model; instead, it lets the data reveal the factor structure. It's commonly used in fields 

like psychology, social sciences, education, and marketing to develop or validate questionnaires, 

scales, or tests by grouping related items. 

STEPS in EFA 

In EFA, several key actions (or steps/options) are performed to extract, refine, and interpret 
factors. 

1.Data Preparation: 

Definition: Cleaning and selecting variables for analysis. 

Explanation: Ensure no missing values (or handle them, e.g., via mean imputation or 

listwise deletion). Select only relevant variables (e.g., exclude IDs or demographics). Check 

assumptions like normality (via histograms or tests) and correlations (matrix should show 

patterns). In SPSS, this is done before running the analysis. 

2.Suitability Testing: 

Definition: Assessing if the data is appropriate for EFA. 



Explanation: Use KMO (Kaiser-Meyer-Olkin) measure (>0.6 indicates adequate sampling) 

and Bartlett's Test of Sphericity (p < 0.05 means correlations are not zero). This prevents 

running EFA on unfactorable data. 

3. Factor Extraction: 

Definition: Methods to identify initial factors from the correlation matrix. 

Explanation: Common methods include Principal Component Analysis (PCA, maximizes 

total variance; often used for data reduction) or Principal Axis Factoring (PAF, focuses on 

common variance; better for latent constructs). Extract factors based on criteria like 

eigenvalues >1 (Kaiser rule) or scree plot (visual "elbow" where variance drops). 

4.Factor Rotation: 

Definition: Adjusting factors to make the structure clearer and more interpretable. 

Explanation: Unrotated factors can be hard to interpret due to mixed loadings. Orthogonal 

rotations (e.g., Varimax) assume independent factors and maximize high/low loadings. 

Oblique rotations (e.g., Promax) allow correlated factors, which is realistic in many cases 

(e.g., personality traits overlap). Rotation doesn't change the data but redistributes variance 

for simplicity. 

5. Factor Retention: 

Definition: Deciding how many factors to keep. 

Explanation: Use multiple criteria: eigenvalues >1, scree plot, parallel analysis (compares to 

random data), or variance explained (>60% cumulative). Over-retaining leads to noise; 

under-retaining loses information. 

6.  Item Refinement: 

Definition: Removing or adjusting problematic variables. 



Explanation: Based on communalities (<0.3-0.5 means low explained variance), loadings 

(<0.4-0.5 or cross-loadings >0.3), or reliability (e.g., Cronbach's alpha per factor >0.7). 

Rerun EFA after removal for cleaner structure. 

7.Scoring and Further Analysis: 

Definition: Computing factor scores for use in other analyses. 

Explanation: Save scores (e.g., regression method) for each case, then use in regression, 

clustering, or validation. This turns factors into usable variables. 

Step-by-Step Process: 

1. Open your dataset in SPSS using 

File → Open → Data and load the required data file. 

2. Go to Analyze → Dimension Reduction → Factor to begin Exploratory Factor 

Analysis. 

3. In the Factor Analysis dialog box, move the selected variables (x1 to x9) into the 

Variables box. 

4. Click on Descriptives, select Univariate  descriptive, coefficients, KMO and Bartlett’s 

Test of Sphericity and Anti-image correlations, then click Continue. 

5. Click on Extraction, choose Principal Component as the extraction method, select 

Eigen values greater than 1, and select correlation matrix, and check Scree plot, then 

click Continue. 

6. Click on Rotation, select Varimax rotation, check Rotated solution, and click 

Continue. 

7. Click on Scores, select Save as variables using the Regression method, and click 

Continue. 

8. Click options, select exclude cases listwise and select “sorted by size”,and click continue. 

9. Click OK to run the Exploratory Factor Analysis. 

10. Examine the output, including the KMO and Bartlett’s Test, Total Variance 

Explained, Scree Plot, and Rotated Factor Matrix to determine the number of factors 

and item loadings. 



GET DATA

  /TYPE=XLSX

  /FILE='C:\Users\sitams.LAB6-06\Downloads\bfi_efa.xlsx'

  /SHEET=name 'bfi'

  /CELLRANGE=FULL

  /READNAMES=ON

  /DATATYPEMIN PERCENTAGE=95.0

  /HIDDEN IGNORE=YES.

EXECUTE.

DATASET NAME DataSet6 WINDOW=FRONT.

FACTOR

  /VARIABLES A1 A2 A3 A4 A5 C1 C2 C3 C4 C5 E1 E2 E3 E4 E5 N1 N2 N3 N4 N5 O1 O2

 O3 O4 O5

  /MISSING LISTWISE

  /ANALYSIS A1 A2 A3 A4 A5 C1 C2 C3 C4 C5 E1 E2 E3 E4 E5 N1 N2 N3 N4 N5 O1 O2 

O3 O4 O5

  /PRINT UNIVARIATE INITIAL CORRELATION KMO AIC EXTRACTION ROTATION

  /FORMAT SORT BLANK(.10)

  /PLOT EIGEN

  /CRITERIA MINEIGEN(1) ITERATE(25)

  /EXTRACTION PC

  /CRITERIA ITERATE(25)

  /ROTATION VARIMAX

  /SAVE REG(ALL)

  /METHOD=CORRELATION.

Factor Analysis

[DataSet6] 
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Descriptive Statistics

Mean Std. Deviation Analysis N

A1

A2

A3

A4

A5

C1

C2

C3

C4

C5

E1

E2

E3

E4

E5

N1

N2

N3

N4

N5

O1

O2

O3

O4

O5

2.41 1.407 2436

4.80 1.180 2436

4.60 1.311 2436

4.69 1.485 2436

4.54 1.271 2436

4.53 1.235 2436

4.37 1.319 2436

4.30 1.291 2436

2.55 1.377 2436

3.31 1.633 2436

2.98 1.631 2436

3.15 1.614 2436

3.98 1.352 2436

4.41 1.467 2436

4.39 1.343 2436

2.94 1.576 2436

3.52 1.533 2436

3.22 1.595 2436

3.20 1.570 2436

2.97 1.623 2436

4.81 1.127 2436

2.68 1.553 2436

4.45 1.205 2436

4.93 1.193 2436

2.47 1.324 2436
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Correlation Matrix

A1 A2 A3 A4 A5 C1 C2

Correlation A1

A2

A3

A4

A5

C1

C2

C3

C4

C5

E1

E2

E3

E4

E5

N1

N2

N3

N4

N5

O1

O2

O3

O4

O5

1.000 -.351 -.274 -.157 -.193 .015 .013

-.351 1.000 .503 .351 .397 .103 .130

-.274 .503 1.000 .385 .516 .114 .147

-.157 .351 .385 1.000 .326 .095 .226

-.193 .397 .516 .326 1.000 .135 .117

.015 .103 .114 .095 .135 1.000 .438

.013 .130 .147 .226 .117 .438 1.000

-.021 .189 .129 .133 .131 .317 .363

.115 -.146 -.121 -.172 -.126 -.362 -.396

.038 -.121 -.154 -.250 -.167 -.261 -.304

.107 -.222 -.210 -.134 -.252 -.031 .017

.088 -.243 -.292 -.210 -.338 -.107 -.075

-.049 .255 .383 .204 .412 .135 .153

-.070 .297 .388 .319 .483 .153 .123

-.020 .294 .253 .169 .269 .268 .258

.168 -.094 -.083 -.107 -.205 -.072 -.020

.140 -.050 -.092 -.155 -.199 -.038 -.006

.092 -.040 -.039 -.074 -.138 -.025 .003

.042 -.087 -.127 -.171 -.215 -.098 -.044

.015 .020 -.040 -.015 -.081 -.048 .051

.006 .126 .150 .057 .163 .179 .161

.066 .014 .007 .038 -.007 -.129 -.057

-.064 .165 .226 .071 .238 .197 .193

-.091 .083 .032 -.050 .011 .100 .047

.099 -.081 -.042 .027 -.050 -.130 -.067
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Correlation Matrix

C3 C4 C5 E1 E2 E3 E4

Correlation A1

A2

A3

A4

A5

C1

C2

C3

C4

C5

E1

E2

E3

E4

E5

N1

N2

N3

N4

N5

O1

O2

O3

O4

O5

-.021 .115 .038 .107 .088 -.049 -.070

.189 -.146 -.121 -.222 -.243 .255 .297

.129 -.121 -.154 -.210 -.292 .383 .388

.133 -.172 -.250 -.134 -.210 .204 .319

.131 -.126 -.167 -.252 -.338 .412 .483

.317 -.362 -.261 -.031 -.107 .135 .153

.363 -.396 -.304 .017 -.075 .153 .123

1.000 -.358 -.351 -.009 -.089 .093 .100

-.358 1.000 .488 .098 .208 -.085 -.113

-.351 .488 1.000 .068 .266 -.163 -.207

-.009 .098 .068 1.000 .469 -.323 -.420

-.089 .208 .266 .469 1.000 -.386 -.527

.093 -.085 -.163 -.323 -.386 1.000 .417

.100 -.113 -.207 -.420 -.527 .417 1.000

.207 -.235 -.235 -.307 -.383 .391 .323

-.079 .216 .216 .015 .176 -.047 -.144

-.067 .158 .246 .020 .207 -.060 -.152

-.077 .202 .242 .055 .193 -.017 -.123

-.122 .271 .355 .235 .351 -.147 -.306

-.024 .197 .179 .054 .259 -.080 -.104

.091 -.094 -.086 -.105 -.158 .328 .138

-.030 .208 .123 .049 .079 -.074 .050

.059 -.083 -.074 -.217 -.238 .406 .215

.011 .053 .135 .094 .172 .053 -.099

-.003 .190 .056 .089 .081 -.123 .047
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Correlation Matrix

E5 N1 N2 N3 N4 N5 O1

Correlation A1

A2

A3

A4

A5

C1

C2

C3

C4

C5

E1

E2

E3

E4

E5

N1

N2

N3

N4

N5

O1

O2

O3

O4

O5

-.020 .168 .140 .092 .042 .015 .006

.294 -.094 -.050 -.040 -.087 .020 .126

.253 -.083 -.092 -.039 -.127 -.040 .150

.169 -.107 -.155 -.074 -.171 -.015 .057

.269 -.205 -.199 -.138 -.215 -.081 .163

.268 -.072 -.038 -.025 -.098 -.048 .179

.258 -.020 -.006 .003 -.044 .051 .161

.207 -.079 -.067 -.077 -.122 -.024 .091

-.235 .216 .158 .202 .271 .197 -.094

-.235 .216 .246 .242 .355 .179 -.086

-.307 .015 .020 .055 .235 .054 -.105

-.383 .176 .207 .193 .351 .259 -.158

.391 -.047 -.060 -.017 -.147 -.080 .328

.323 -.144 -.152 -.123 -.306 -.104 .138

1.000 .034 .039 -.065 -.207 -.142 .291

.034 1.000 .718 .567 .410 .381 -.051

.039 .718 1.000 .550 .395 .351 -.043

-.065 .567 .550 1.000 .523 .431 -.040

-.207 .410 .395 .523 1.000 .403 -.049

-.142 .381 .351 .431 .403 1.000 -.129

.291 -.051 -.043 -.040 -.049 -.129 1.000

-.085 .135 .117 .104 .074 .187 -.230

.306 -.039 -.030 -.028 -.063 -.080 .393

-.001 .079 .131 .166 .220 .111 .177

-.113 .106 .024 .057 .036 .138 -.246
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Correlation Matrix

O2 O3 O4 O5

Correlation A1

A2

A3

A4

A5

C1

C2

C3

C4

C5

E1

E2

E3

E4

E5

N1

N2

N3

N4

N5

O1

O2

O3

O4

O5

.066 -.064 -.091 .099

.014 .165 .083 -.081

.007 .226 .032 -.042

.038 .071 -.050 .027

-.007 .238 .011 -.050

-.129 .197 .100 -.130

-.057 .193 .047 -.067

-.030 .059 .011 -.003

.208 -.083 .053 .190

.123 -.074 .135 .056

.049 -.217 .094 .089

.079 -.238 .172 .081

-.074 .406 .053 -.123

.050 .215 -.099 .047

-.085 .306 -.001 -.113

.135 -.039 .079 .106

.117 -.030 .131 .024

.104 -.028 .166 .057

.074 -.063 .220 .036

.187 -.080 .111 .138

-.230 .393 .177 -.246

1.000 -.284 -.075 .328

-.284 1.000 .184 -.310

-.075 .184 1.000 -.182

.328 -.310 -.182 1.000

KMO and Bartlett's Test

Kaiser-Meyer-Olkin Measure of Sampling Adequacy.

Bartlett's Test of Sphericity Approx. Chi-Square

df

Sig.

.849

18146.066

300

.000
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Anti-image Matrices

A1 A2 A3 A4 A5 C1

Anti-image Covariance A1

A2

A3

A4

A5

C1

C2

C3

C4

C5

E1

E2

E3

E4

E5

N1

N2

N3

N4

N5

O1

O2

O3

O4

O5

Anti-image Correlation A1

A2

A3

A4

A5

C1

C2

C3

C4

C5

.799 .168 .089 .019 .021 -.035

.168 .607 -.157 -.106 -.060 .015

.089 -.157 .567 -.102 -.148 -.003

.019 -.106 -.102 .730 -.044 .035

.021 -.060 -.148 -.044 .582 -.015

-.035 .015 -.003 .035 -.015 .706

-.034 .016 -.011 -.101 .018 -.173

-.028 -.078 -.001 .026 -.018 -.090

-.060 .010 -.002 .013 -.002 .098

.013 -.020 .005 .075 -.012 .022

-.045 .032 -.020 -.007 -.001 -.025

-.005 .017 .015 -.008 .005 -.017

-.036 .014 -.079 -.001 -.087 .022

-.036 -.013 -.040 -.068 -.121 -.051

-.034 -.095 .009 .010 -.015 -.070

-.037 .033 -.018 -.022 .034 .017

-.026 -.029 .002 .050 .023 .000

-.015 .006 -.015 -.020 .009 -.029

.026 -.021 -.004 .028 .010 .008

.026 -.046 .021 -.021 -.022 -.002

-.047 -.010 -.004 .004 -.002 -.023

-.036 -.031 -.015 -.019 -.015 .028

.006 .007 -.030 .029 -.024 -.033

.067 -.043 .003 .017 -.015 -.065

-.032 .028 -.014 -.020 .003 .026

.754a .241 .132 .024 .031 -.046

.241 .836a -.267 -.159 -.101 .023

.132 -.267 .870a -.159 -.258 -.004

.024 -.159 -.159 .878a -.068 .048

.031 -.101 -.258 -.068 .904a -.024

-.046 .023 -.004 .048 -.024 .843a

-.047 .025 -.018 -.147 .029 -.257

-.036 -.117 -.002 .036 -.027 -.124

-.088 .016 -.004 .019 -.004 .152

.019 -.033 .009 .112 -.019 .034
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Anti-image Matrices

C2 C3 C4 C5 E1 E2

Anti-image Covariance A1

A2

A3

A4

A5

C1

C2

C3

C4

C5

E1

E2

E3

E4

E5

N1

N2

N3

N4

N5

O1

O2

O3

O4

O5

Anti-image Correlation A1

A2

A3

A4

A5

C1

C2

C3

C4

C5

-.034 -.028 -.060 .013 -.045 -.005

.016 -.078 .010 -.020 .032 .017

-.011 -.001 -.002 .005 -.020 .015

-.101 .026 .013 .075 -.007 -.008

.018 -.018 -.002 -.012 -.001 .005

-.173 -.090 .098 .022 -.025 -.017

.642 -.111 .137 .042 -.061 -.020

-.111 .745 .092 .118 -.017 -.015

.137 .092 .585 -.174 -.038 -.027

.042 .118 -.174 .624 .058 -.048

-.061 -.017 -.038 .058 .668 -.151

-.020 -.015 -.027 -.048 -.151 .542

-.015 .005 -.031 .034 .055 .054

-.009 .015 -.030 .013 .108 .143

-.058 -.033 .023 .028 .064 .080

.003 .001 -.035 .016 .024 .008

-.006 .002 .029 -.044 .018 -.034

-.004 .008 -.010 -.013 .008 .011

-.029 .004 -.033 -.089 -.074 -.028

-.073 -.020 -.049 .014 .059 -.082

-.028 -.015 -.022 -.006 -.019 -.002

-.030 -.020 -.079 -.033 -.018 -.007

-.073 .018 -.051 -.017 .041 .026

.005 -.019 -.018 -.050 -.043 -.080

-.015 -.051 -.082 .006 -.040 -.017

-.047 -.036 -.088 .019 -.062 -.007

.025 -.117 .016 -.033 .051 .029

-.018 -.002 -.004 .009 -.033 .027

-.147 .036 .019 .112 -.010 -.013

.029 -.027 -.004 -.019 -.002 .010

-.257 -.124 .152 .034 -.036 -.027

.796a -.160 .223 .066 -.093 -.034

-.160 .852a .139 .173 -.024 -.023

.223 .139 .827a -.287 -.062 -.047

.066 .173 -.287 .864a .091 -.082
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Anti-image Matrices

E3 E4 E5 N1 N2 N3

Anti-image Covariance A1

A2

A3

A4

A5

C1

C2

C3

C4

C5

E1

E2

E3

E4

E5

N1

N2

N3

N4

N5

O1

O2

O3

O4

O5

Anti-image Correlation A1

A2

A3

A4

A5

C1

C2

C3

C4

C5

-.036 -.036 -.034 -.037 -.026 -.015

.014 -.013 -.095 .033 -.029 .006

-.079 -.040 .009 -.018 .002 -.015

-.001 -.068 .010 -.022 .050 -.020

-.087 -.121 -.015 .034 .023 .009

.022 -.051 -.070 .017 .000 -.029

-.015 -.009 -.058 .003 -.006 -.004

.005 .015 -.033 .001 .002 .008

-.031 -.030 .023 -.035 .029 -.010

.034 .013 .028 .016 -.044 -.013

.055 .108 .064 .024 .018 .008

.054 .143 .080 .008 -.034 .011

.602 -.062 -.085 .000 .008 -.034

-.062 .528 -.011 .019 -.005 -.012

-.085 -.011 .633 -.054 -.048 .027

.000 .019 -.054 .410 -.230 -.099

.008 -.005 -.048 -.230 .428 -.092

-.034 -.012 .027 -.099 -.092 .524

-.003 .055 .039 -.039 -.013 -.157

.000 -.015 .062 -.054 -.024 -.099

-.099 -.003 -.085 -.001 .012 .005

-.015 -.051 -.008 -.009 -.024 .006

-.119 -.019 -.048 -.009 .004 .013

-.023 .013 .009 .020 -.023 -.036

.011 -.075 -.007 -.043 .039 -5.371E-5

-.052 -.055 -.047 -.064 -.044 -.023

.023 -.023 -.154 .066 -.057 .010

-.136 -.072 .016 -.038 .004 -.028

-.002 -.109 .015 -.039 .090 -.033

-.146 -.218 -.025 .069 .045 .017

.034 -.084 -.105 .031 .001 -.048

-.025 -.016 -.091 .006 -.010 -.007

.008 .023 -.048 .002 .004 .013

-.052 -.055 .038 -.071 .059 -.017

.056 .022 .045 .031 -.085 -.023
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Anti-image Matrices

N4 N5 O1 O2 O3 O4

Anti-image Covariance A1

A2

A3

A4

A5

C1

C2

C3

C4

C5

E1

E2

E3

E4

E5

N1

N2

N3

N4

N5

O1

O2

O3

O4

O5

Anti-image Correlation A1

A2

A3

A4

A5

C1

C2

C3

C4

C5

.026 .026 -.047 -.036 .006 .067

-.021 -.046 -.010 -.031 .007 -.043

-.004 .021 -.004 -.015 -.030 .003

.028 -.021 .004 -.019 .029 .017

.010 -.022 -.002 -.015 -.024 -.015

.008 -.002 -.023 .028 -.033 -.065

-.029 -.073 -.028 -.030 -.073 .005

.004 -.020 -.015 -.020 .018 -.019

-.033 -.049 -.022 -.079 -.051 -.018

-.089 .014 -.006 -.033 -.017 -.050

-.074 .059 -.019 -.018 .041 -.043

-.028 -.082 -.002 -.007 .026 -.080

-.003 .000 -.099 -.015 -.119 -.023

.055 -.015 -.003 -.051 -.019 .013

.039 .062 -.085 -.008 -.048 .009

-.039 -.054 -.001 -.009 -.009 .020

-.013 -.024 .012 -.024 .004 -.023

-.157 -.099 .005 .006 .013 -.036

.561 -.101 -.021 .014 -.008 -.059

-.101 .682 .050 -.059 -.006 -.016

-.021 .050 .744 .083 -.125 -.086

.014 -.059 .083 .786 .133 .003

-.008 -.006 -.125 .133 .647 -.080

-.059 -.016 -.086 .003 -.080 .822

.007 -.043 .073 -.145 .120 .090

.038 .036 -.060 -.045 .008 .083

-.035 -.071 -.015 -.045 .011 -.061

-.006 .033 -.006 -.023 -.049 .004

.044 -.030 .006 -.025 .043 .022

.018 -.034 -.003 -.022 -.039 -.022

.012 -.002 -.032 .037 -.050 -.085

-.049 -.110 -.041 -.042 -.113 .007

.006 -.028 -.020 -.027 .027 -.024

-.058 -.077 -.034 -.116 -.083 -.027

-.150 .021 -.008 -.048 -.027 -.069
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Anti-image Matrices

O5

Anti-image Covariance A1

A2

A3

A4

A5

C1

C2

C3

C4

C5

E1

E2

E3

E4

E5

N1

N2

N3

N4

N5

O1

O2

O3

O4

O5

Anti-image Correlation A1

A2

A3

A4

A5

C1

C2

C3

C4

C5

-.032

.028

-.014

-.020

.003

.026

-.015

-.051

-.082

.006

-.040

-.017

.011

-.075

-.007

-.043

.039

-5.371E-5

.007

-.043

.073

-.145

.120

.090

.768

-.041

.041

-.020

-.026

.005

.035

-.021

-.067

-.122

.008
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Anti-image Matrices

A1 A2 A3 A4 A5 C1

E1

E2

E3

E4

E5

N1

N2

N3

N4

N5

O1

O2

O3

O4

O5

-.062 .051 -.033 -.010 -.002 -.036

-.007 .029 .027 -.013 .010 -.027

-.052 .023 -.136 -.002 -.146 .034

-.055 -.023 -.072 -.109 -.218 -.084

-.047 -.154 .016 .015 -.025 -.105

-.064 .066 -.038 -.039 .069 .031

-.044 -.057 .004 .090 .045 .001

-.023 .010 -.028 -.033 .017 -.048

.038 -.035 -.006 .044 .018 .012

.036 -.071 .033 -.030 -.034 -.002

-.060 -.015 -.006 .006 -.003 -.032

-.045 -.045 -.023 -.025 -.022 .037

.008 .011 -.049 .043 -.039 -.050

.083 -.061 .004 .022 -.022 -.085

-.041 .041 -.020 -.026 .005 .035

Anti-image Matrices

C2 C3 C4 C5 E1 E2

E1

E2

E3

E4

E5

N1

N2

N3

N4

N5

O1

O2

O3

O4

O5

-.093 -.024 -.062 .091 .838a -.251

-.034 -.023 -.047 -.082 -.251 .884a

-.025 .008 -.052 .056 .087 .095

-.016 .023 -.055 .022 .182 .268

-.091 -.048 .038 .045 .098 .137

.006 .002 -.071 .031 .045 .017

-.010 .004 .059 -.085 .034 -.071

-.007 .013 -.017 -.023 .014 .020

-.049 .006 -.058 -.150 -.120 -.051

-.110 -.028 -.077 .021 .087 -.134

-.041 -.020 -.034 -.008 -.027 -.003

-.042 -.027 -.116 -.048 -.024 -.011

-.113 .027 -.083 -.027 .062 .045

.007 -.024 -.027 -.069 -.058 -.120

-.021 -.067 -.122 .008 -.056 -.026
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Anti-image Matrices

E3 E4 E5 N1 N2 N3

E1

E2

E3

E4

E5

N1

N2

N3

N4

N5

O1

O2

O3

O4

O5

.087 .182 .098 .045 .034 .014

.095 .268 .137 .017 -.071 .020

.897a -.110 -.138 .000 .015 -.060

-.110 .877a -.019 .041 -.010 -.023

-.138 -.019 .893a -.105 -.092 .046

.000 .041 -.105 .779a -.548 -.214

.015 -.010 -.092 -.548 .780a -.194

-.060 -.023 .046 -.214 -.194 .862a

-.005 .101 .066 -.082 -.026 -.290

.000 -.026 .094 -.103 -.044 -.166

-.148 -.006 -.125 -.001 .022 .008

-.022 -.080 -.012 -.016 -.042 .009

-.191 -.032 -.076 -.017 .007 .022

-.033 .019 .012 .034 -.039 -.055

.017 -.117 -.011 -.077 .069 -8.467E-5

Anti-image Matrices

N4 N5 O1 O2 O3 O4

E1

E2

E3

E4

E5

N1

N2

N3

N4

N5

O1

O2

O3

O4

O5

-.120 .087 -.027 -.024 .062 -.058

-.051 -.134 -.003 -.011 .045 -.120

-.005 .000 -.148 -.022 -.191 -.033

.101 -.026 -.006 -.080 -.032 .019

.066 .094 -.125 -.012 -.076 .012

-.082 -.103 -.001 -.016 -.017 .034

-.026 -.044 .022 -.042 .007 -.039

-.290 -.166 .008 .009 .022 -.055

.885a -.163 -.032 .021 -.014 -.086

-.163 .860a .070 -.081 -.009 -.022

-.032 .070 .859a .108 -.181 -.110

.021 -.081 .108 .780a .187 .004

-.014 -.009 -.181 .187 .844a -.110

-.086 -.022 -.110 .004 -.110 .770a

.011 -.060 .096 -.187 .170 .114
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Anti-image Matrices

O5

E1

E2

E3

E4

E5

N1

N2

N3

N4

N5

O1

O2

O3

O4

O5

-.056

-.026

.017

-.117

-.011

-.077

.069

-8.467E-5

.011

-.060

.096

-.187

.170

.114

.762a

Measures of Sampling Adequacy(MSA)a. 
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Communalities

Initial Extraction

A1

A2

A3

A4

A5

C1

C2

C3

C4

C5

E1

E2

E3

E4

E5

N1

N2

N3

N4

N5

O1

O2

O3

O4

O5

1.000 .658

1.000 .610

1.000 .608

1.000 .426

1.000 .579

1.000 .500

1.000 .603

1.000 .479

1.000 .672

1.000 .545

1.000 .604

1.000 .637

1.000 .584

1.000 .624

1.000 .509

1.000 .745

1.000 .727

1.000 .645

1.000 .588

1.000 .482

1.000 .533

1.000 .515

1.000 .580

1.000 .486

1.000 .563

Extraction Method: Principal 
Component Analysis.
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Total Variance Explained

Component

Initial Eigenvalues Extraction Sums of Squared Loadings

Total % of Variance Cumulative % Total % of Variance Cumulative %

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

24

25

5.134 20.537 20.537 5.134 20.537 20.537

2.752 11.008 31.545 2.752 11.008 31.545

2.143 8.571 40.116 2.143 8.571 40.116

1.852 7.409 47.525 1.852 7.409 47.525

1.548 6.193 53.718 1.548 6.193 53.718

1.074 4.294 58.012 1.074 4.294 58.012

.840 3.358 61.370

.799 3.197 64.567

.719 2.876 67.443

.688 2.752 70.195

.676 2.705 72.901

.652 2.607 75.508

.623 2.493 78.001

.597 2.386 80.387

.563 2.252 82.640

.543 2.173 84.813

.515 2.058 86.871

.495 1.978 88.849

.483 1.931 90.779

.449 1.796 92.575

.423 1.693 94.269

.401 1.603 95.871

.388 1.551 97.422

.382 1.527 98.950

.263 1.050 100.000
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Total Variance Explained

Component

Rotation Sums of Squared Loadings

Total % of Variance Cumulative %

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

24

25

3.093 12.371 12.371

2.593 10.373 22.744

2.577 10.306 33.051

2.533 10.131 43.182

2.095 8.382 51.563

1.612 6.449 58.012

Extraction Method: Principal Component Analysis.
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Component Number

25242322212019181716151413121110987654321

E
ig

en
v

al
u

e

6

5

4

3

2

1

0

Scree Plot

Component Matrixa

Component

1 2 3 4 5 6

E2

E4

A5

E3

A3

E5

N4

C5

A2

C4

A4

E1

N3

N2

N1

N5

-.642 .259 .348 .172

.622 .166 -.377 -.217 .116

.613 .189 -.308 .188 .194

.563 .360 -.136 -.207 -.155 .229

.557 .316 -.295 .318

.553 .312 -.307

-.547 .481 .214

-.524 .190 -.294 -.351 .108 .117

.496 .313 -.225 .123 .415 -.169

-.493 .132 -.477 -.279 .326

.457 .125 -.190 .328 .235

-.443 -.193 .327 .157 .336 .355

-.415 .672

-.425 .653 -.229 -.237

-.437 .652 .118 -.282 -.186

-.369 .500 .271 .137
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Component Matrixa

Component

1 2 3 4 5 6

C1

C2

O5

O3

O2

C3

O1

A1

O4

.376 .154 .523 .209 .130

.361 .216 .506 .382 .154

-.225 -.369 .507 -.150 .300

.434 .331 .195 -.473 .140

-.219 -.412 .459 .281

.350 .394 .441

.361 .247 .271 -.420 .300

-.250 .173 -.610 .437

.340 .258 -.286 .414 .214

Extraction Method: Principal Component Analysis.

6 components extracted.a. 

Rotated Component Matrixa

Component

1 2 3 4 5 6

N1

N2

N3

N4

N5

C2

C4

C3

C1

C5

A2

A3

A1

A5

A4

E1

E2

E4

.837 -.166

.835 -.151

.795

.617 -.171 .418

.608 .140 .216 .199

.738 .201

.186 -.689 .162 .150 .325

.678 .123

.653 .263

.284 -.625 .236

.120 .749 -.145

.710 -.195 .228

-.661 .224 .393

-.190 .584 -.254 .328 .163

.249 .548 -.128 .196

-.189 .729 .154

.214 -.187 .728 -.134

-.146 .352 -.582 .253 .261
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Rotated Component Matrixa

Component

1 2 3 4 5 6

E5

O4

O1

O3

E3

O5

O2

.333 .113 -.512 .335

.193 .170 .434 .430 -.215

.116 .689 -.194

.105 -.181 .663 -.305

.261 -.416 .579

-.249 .704

.149 -.184 .662

Extraction Method: Principal Component Analysis. 
 Rotation Method: Varimax with Kaiser Normalization.

Rotation converged in 7 iterations.a. 

Component Transformation Matrix

Component 1 2 3 4 5 6

1

2

3

4

5

6

-.442 .429 .477 -.513 .339 -.120

.845 .067 .301 -.117 .421 .011

.055 .682 -.408 .369 .187 -.441

.152 .584 .181 .043 -.530 .567

-.112 -.076 .683 .681 -.058 -.217

-.228 .006 -.123 .347 .624 .650

Extraction Method: Principal Component Analysis.  
 Rotation Method: Varimax with Kaiser Normalization.
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RESULT: 

The dataset was successfully tested and found suitable for Exploratory Factor 

Analysis.Meaningful factors were successfully extracted and rotated for clear interpretation. The 

extracted factors were validated and confirmed to be reliable. 



Cluster Analysis 

Aim:  

To apply cluster analysis on the Iris dataset to group the flower observations into  3 clusters 

based on their measurements (sepal length, sepal width, petal length, petal width), using 

unsupervised methods. 

Description: 

Definition of Cluster Analysis: 

Cluster analysis is an unsupervised machine learning technique that partitions a dataset into 

groups (clusters) based on similarity in features, without relying on predefined labels. 

Similarities are typically measured using distance metrics like Euclidean distance. 

Types of Cluster Analysis: 

1. Hierarchical Clustering: An agglomerative (bottom-up) approach that starts with each 

data point as a single cluster and merges them iteratively based on linkage criteria (e.g., 

Ward's method minimizes variance). Produces a dendrogram for visualizing cluster 

hierarchy. 

2. K-Means Clustering: A partitioning algorithm that assigns data points to a fixed number 

of clusters (k=3 here) by iteratively updating cluster centroids to minimize the sum of 

squared distances within clusters. 

3. Two-Step Clustering: A hybrid scalable method that first pre-clusters data into many 

small sub-clusters (using log-likelihood or Euclidean distance), then applies hierarchical 

clustering to merge them. It can handle large datasets and mixed variable types. 

 

 



Formula for Z-Score Standardization: To prevent variables with larger scales from 

dominating distance calculations, standardize each feature using Z-scores: 

 Z = (x - μ) / σ 

 x: Original value 

 μ: Mean of the variable across all observations 

 σ: Standard deviation of the variable This scales all variables to mean=0 and SD=1. 

Data Preprocessing: Import and Standardize the Iris Dataset in SPSS 

1. Open SPSS. 

2. Import Excel File: 

 File → Import Data → Excel 

 Select "irisdataexcel.xlsx". 

 Choose Sheet1 (it contains the data). 

 Check Read variable names from the first row. 

 OK . 

 Define Variables:Variable View → Set numeric variables to Scale; target to Nominal.  

 Standardize Variables: 

 Analyze → Descriptive Statistics → Descriptives. 

 Move  all 4  variables to Variable(s). 

 Check Save standardized values as variables. 

 OK → Creates Zpetal length (cm), Zpetal width (cm), etc. Use these for 

clustering. 

 

 

 

 



Method 1: Hierarchical Cluster Analysis (For 3 Clusters) 

Uses Ward's method for balanced clusters; dendrogram helps confirm 3 is suitable. 

1. Analyze → Classify → Hierarchical Cluster… 

2. Variables: Move Zpetal length (cm), Zpetal width (cm) to Variable(s). (Ignore target.) 

3. Cluster: Cases (default). 

4. Click Method: Cluster Method → Ward’s method; Measure → Squared Euclidean 

distance. OK. 

5. Click Statistics: Agglomeration schedule; Cluster Membership → Single solution → 3. 

OK. 

6. Click Plots: Dendrogram. OK. 

7. Click Save: Cluster membership → Single solution → 3 (creates new variable, e.g., 

CLU3_1). OK. 

8. OK to run. 

9. Interpret: Dendrogram shows clear 3-cluster cut; crosstab CLU3_1 vs. target for match 

(~83% with all features, higher with petals). 

Method 2: K-Means Cluster Analysis (Force 3 Clusters) 

Iterative partitioning; random initialization may vary results slightly—rerun if needed for best 

match. 

1. Analyze → Classify → K-Means Cluster… 

2. Variables: Move Zpetal length (cm), Zpetal width (cm) to Variable(s). (Ignore target.) 

3. Number of Clusters: 3. 

4. Click Iterate: Max iterations 10, Convergence 0 (default). 

5. Click Save: Cluster membership (creates QCL_1). 

6. Click Options: Initial cluster centers, ANOVA table. OK. 

7. OK to run. 

8. Interpret: Cluster Centers table shows group means (e.g., small petals = setosa); ANOVA 

identifies key variables. Crosstab QCL_1 vs. target (~96% match with petals). 






















